Übersicht Übersicht Ebene Ebene
Software für OS/2 und eCS
Download details

Apache OpenOffice Apache OpenOffice

** Apache OpenOffice 4.1.2 for eComStation and OS/2 **

Welcome to the GA version of Apache OpenOffice 4.1.2 for eComStation and OS/2.
Apache OpenOffice is comprised of six personal productivity applications: a
word processor (and its web-authoring component), spreadsheet, presentation
graphics, drawing, equation editor, and database.


** Warning **
Do not install this version over an existing installation.


** Features **

- NLS:
Apache OpenOffice for eComStation and OS/2 is released in English,
German, Italian, French, Spanish, Dutch and Russian.

- Internet integration:
- e-mail related settings are now supported, you can email your current
document, but only Thunderbird is supported (see below).
- The default OS/2 browser will be used for opening web pages from URL
links in documents (see below).

- Desktop integration:
- support for WPS integration via separate package
- support for the FreeType2 (FT2) font engine for improved text rendering
- support for XWP/eWPS sliding menu hilite (requires XWorkPlace 1.0.8 or
eCS 2.0 RC4 or newer)
- support for clipboard bitmap formats and unicode text
- support for mouse wheel

- Quickstart:
the quickstart feature has been implemented for eComStation and OS/2.


** Additional information **

- The main Apache OpenOffice.org readme may be found online here:
https://cwiki.apache.org/confluence/display/OOOUSERS/AOO+4.1.2+Release+Notes

- Information on the OS/2 version of Apache OpenOffice may be found here:
http://www.bitwiseworks.com

- You may contribute to the development of the Apache OpenOffice for
eComStation and OS/2. Please visit the following page to make your donation:
http://www.bitwiseworks.com/shop


** Installation notes **

- You need only one WPI for you preferred language. For additional languages
you need only the language WPI to install.

- This installation can be used alongside Apache OpenOffice 1.1.5,
OpenOffice.org 2.x, and OpenOffice.org 3.x releases.

- Installation should preferably be done on a JFS volume, as it may
run slowly otherwise. The installation target volume must support long
filenames.

- Installation takes approximately 400 MB of drivespace.

- During installation, a template folder is created which holds a large number
of templates which can be used as a base for Apache OpenOffice documents.

- For better rendering of the GUI font, it is suggested to install Workplace
Sans TrueType font. This will also visualize the numbering for the vertical
ruler, since the default font, WarpSans, cannot be rotated. It is advised to
install this font prior to installing Apache OpenOffice.

This font is available by default in eComStation 2.x, or may be obtained from:
http://www.altsan.org/creative/fonts/workplace/

- Internet Application Integration (optional)

This tool is installed and configured by default in eComStation 2.x.

You may download it from the author's website if needed:
https://sites.google.com/site/chuckmckinnis/os-2

When configured properly, it is possible to use Thunderbird for sending
your documents. To enable this feature, the Internet Application
Integration tool must be installed and configured for your email client.
In AOO options, Internet settings, set email program field to 'thunderbird'.
The full path for executable and directories will be taken from your INI
files (IAI settings).

The default OS/2 browser will be used for opening web pages. To enable
this feature, the Internet Application Integration tool must be installed
and configured for your browser.

- Quickstart: To enable quickstart, you can place a shadow of the quickstart
WPS icon object in the startup folder.

Currently AOO cannot be unloaded, you need to 'kill' the open instance. You
can customize the quickstart feature and decide which modules to preload at
system startup. Open the Quickstart object properties and change the
parameters field with:

-writer to preload Writer module
-calc to preload Calc module
-draw to preload Draw module
-math to preload Math module
-base to preload Base module
-impress to preload Impress module
-norestore suppress restart/restore after fatal errors.

You can mix above settings to match your personal preferences. Without
above options, only the AOO core program will be loaded.


** High memory notes **

This build of Apache OpenOffice has been tested with dll loading in high memory.
To enable this feature, you only need to execute the highmem object in your new
AOO installation.

This feature works only with kernel 14.106, it will trap your system with earlier
releases.


** System requirements **

- OS/2 Warp 4 (FP17 or higher) or eComStation 1.x, 2.x
- 32-bit tcpip stack
- UniClip (also available from the AOO download directory)
- The following packages must be installed (dll only):
libc 0.6.6
gcc 4.9.2
gcc 4.7.3
gcc 4.4.4
ssl
curl
jpeg
xslt
libicu
z
xml2
stdcpp
stdcpp6
mmap
pthread
urpo

To install the above requirements you have two choices. Either RPM/YUM
installation or WPI installation:

RPM/YUM installation:

These files can be installed with the following command:

yum install libc libgcc1 libgcc-fwd openssl curl libjpeg libxslt libicu zlib libxml2 mmap pthread urpo libstdc++6 libstdc++

(all one line)

WPI installation:

Download the AOO-4120-GA-rpm.wpi before you start the installation.
This WPI is not installable. It's just a helper WPI which can be installed from
the main Apache OpenOffice WPI. This WPI *must* reside in the same directory
where the Apache OpenOffice WPI resides before installation.


** Uninstallation **

Uninstallation could leave some files in the installation directory, remove
them manually.


** Known issues **

- Printing of unicode text could fail, this is an ft2lib issue under
investigation. Bullets are unicode characters, you can use images to
workaround this limit.

- Apache OpenOffice will use high memory for documents, but DLL binary code is
loaded in the low shared arena by OS/2 kernel; this causes it to fail
on some systems. If this happens, Apache OpenOffice will popup an
error message with a reference to the failing DLL.

It may help to set the VIRTUALADDRESSLIMIT to 1536 or 1024 in the
config.sys. With kernel 14.106 it is possible to mark dynamic libraries
for high memory loading (see icons in Extras forlder). Since this feature is
not stable, we cannot apply to code, but testers have found it works in
most situations (be aware, you can trap your system when killing AOO).
Another helpful hint is to use the QuickStart feature described above,
this will 'preload' parts of OpenOffice into memory, which may increase
the success rate of loading OpenOffice.

- Font rendering: Since rendering is done directly with Unicode fonts, it may
happen that some older fonts are not anti-aliased; this means that your font
does not support Unicode charmaps and needs to be upgraded.

- Play of sounds is not working.

- Java 1.6 initial support is included in this release, but not widely tested.

At least Java 1.6 GA3 HotFix 1 is required.

See http://svn.netlabs.org/java for installation details and additional
requirements.

- Macro security not tested (requires Java).

- Digital signatures not tested (requires Java)

- Base module supports dBase, MySQL, ODBC databases.
HSQLDB not tested (requires Java).

- WebDav support is disabled in this build due to SERF library bugs.

- WebDav access to mediacenter.gmx.net requires a directory on first access
(e.g. http://mediacenter.gmx.net/mysubdir).


** Reporting your findings **

If you find any bugs, issues, or have other remarks, please open a
ticket in the Apache Bug Tracker:

https://bz.apache.org/ooo/

If you find any bugs, issues, or have other remarks, please provide as many
details as possible and attach the XXXX.TRP file created at every AOO
crash: this file is located into your X:ApacheOpenOffice.4program
directory.
Also set the ticket to block issue 126518, which is the general tracker
ticket for OS/2 and eComStation development; please check attached tickets
before adding a new one:

https://bz.apache.org/ooo/show_bug.cgi?id=126518


** User Support **

For help with Apache OpenOffice, visit the official support page, here:
http://www.openoffice.org/support/index.html

Additional links are provided on that page to help guide your search.


** (c) 2005-2012 Serenity Systems International **
** (c) 2014-2015 bww bitwise works GmbH **

Version  4.1.2.0  System  ab OS/2 4.0 
Dateigröße  199.81 MB     
Sprache  Deutsch  Erstelldatum  28.02.2015 11:50:45 
Versionsdatum  17.12.2015 01:00:00  Wartung  Zum Zeitpunkt aktiv 
Installertyp  WarpIN  Pakettyp  ZIP 
Lizenz  Apache external  Paketersteller  Ohne Angabe 
    MD5 Prüfsumme  f327df95d60b2afe4ee1258d58c07c38 
Webseite  Webseite external  SHA1 Prüfsumme  e6dee92ad1f37a78eab5ca4be0cacce1f2a972cb 
Dateiname: aoo-4...wpi.zip
Dateigröße: 199.81 MB
Download Mirror 1 Download melden

** Known issues **

- Printing of unicode text could fail, this is an ft2lib issue under
investigation. Bullets are unicode characters, you can use images to
workaround this limit.

- Apache OpenOffice will use high memory for documents, but DLL binary code is
loaded in the low shared arena by OS/2 kernel; this causes it to fail
on some systems. If this happens, Apache OpenOffice will popup an
error message with a reference to the failing DLL.

It may help to set the VIRTUALADDRESSLIMIT to 1536 or 1024 in the
config.sys. With kernel 14.106 it is possible to mark dynamic libraries
for high memory loading (see icons in Extras forlder). Since this feature is
not stable, we cannot apply to code, but testers have found it works in
most situations (be aware, you can trap your system when killing AOO).
Another helpful hint is to use the QuickStart feature described above,
this will 'preload' parts of OpenOffice into memory, which may increase
the success rate of loading OpenOffice.

- Font rendering: Since rendering is done directly with Unicode fonts, it may
happen that some older fonts are not anti-aliased; this means that your font
does not support Unicode charmaps and needs to be upgraded.

- Play of sounds is not working.

- Java 1.6 initial support is included in this release, but not widely tested.

At least Java 1.6 GA3 HotFix 1 is required.

See http://svn.netlabs.org/java for installation details and additional
requirements.

- Macro security not tested (requires Java).

- Digital signatures not tested (requires Java)

- Base module supports dBase, MySQL, ODBC databases.
HSQLDB not tested (requires Java).

- WebDav support is disabled in this build due to SERF library bugs.

- WebDav access to mediacenter.gmx.net requires a directory on first access
(e.g. http://mediacenter.gmx.net/mysubdir).

Zum Seitenanfang